Ask your Question

PEOPLE YOU MIGHT KNOW

Graves Injury
Graves Injury

Vero Beach, FL 32960,  United States
Gauri
Gauri

Student

Pune,  India
Khushi
Khushi

Varanasi,  India
The Dunes
The Dunes

East Hampton, NY 11937 ,  United States
Zhenya
Zhenya

Bansko,  Bulgaria

Write to us

Ask Question

Issue installing/upgrading Magento 2.3.5-p1 [ERROR] InvalidArgumentException: Wrong file

Issue installing/upgrading Magento 2.3.5-p1 [ERROR] InvalidArgumentException: Wrong file

In the new release of Magento 2.3.5-p1 there are many security updates and features but sometimes during installation we face some issue. same in this version while installing getting InvalidArgumentException: Wrong file vendor\magento\framework\Image\Adapter\Gd2.php. Or during upgrading to Magento 2.3.5-p1 from some lower version on product page you will get this error. InvalidArgumentException: Wrong file vendor\magento\framework\Image\Adapter\Gd2.php. Steps to fix Open vendor\magento\framework\Image\Adapter\Gd2.php file. at line 96 and replace function with below one 

 private function validateURLScheme(string $filename) : bool

{

      $allowed_schemes = ['ftp', 'ftps', 'http', 'https'];

      $url = parse_url($filename);

     if ($url && isset($url['scheme']) && !in_array($url['scheme'], $allowed_schemes) && !file_exists($filename)) {

          return false;

      }

     return true

}

This will resolve the issue.

2   0
Himanshi Saini

List Your Business

Improve Your Business Visibility

Please rotate your device

We don't support landscape mode on your device. Please rotate to portrait mode for the best view of our site